Getting Started


Introduction

Welcome to the Browser PRO documentation. In this document we will try to explain what every aspect of the browser does and how it can be used most efficiently. Although the Browser PRO has been developed in such a way that it should take less than an hour to get fully implemented in your workflow. We would advise to just take a nice cup of coffee and read this document through - there are features and functions that could otherwise be missed. We also appreciate feedback or ideas that would make the product stronger and more efficient. So if you feel that something is missing or could be optimized, please let us know: slib@digidim.info
“DGDM - Bringing Studio grade tools to the masses!”


License

One Browser PRO Plug-In is tied to a specific machine at any given time. It is however rehostable, which means it can be transfered from 1 machine to another.


Features

Browser PRO is the most versatile Asset Manager for Autodesk Maya  - greatly helps in organizing and structuring Assets so that they can be easily found and used at a later moment. Browser PRO allows you to export Assets into your library with unparalleled ease.
  • Shader / Asset Import

    • intelligent Import: if a shader or object you want to import is already present in the scene SLiB Browser PRO will reUse it instead of loading it again. this tremendously speeds up the workflow especially when working with heavy assets
    • "Import and Place at Selection" function (objects or components supported)
    • "Import and Replace" function
    • HDRI lighting setups with just a single click
    • import assets as reference, instance or duplicate
    • smart Texture import depending on selection - if a file node is selected it will just swap the texture

  • Asset / Shader Export

    • building up own libraries with unparalleled ease
    • quickly generate preview images by either rendering or taking a scene snapshot
    • batch generation of shader / object thumbnails
    • export with relative textures paths - great for sharing libraries
    • support for multiple render engines (Redshift, Vray, Arnold, etc)
    • add meta data to your Assets

  • SNR - embedded Shading Network Renamer

    • clean and organized shading networks with a single mouseclick
    • all native maya nodes supported + most used vray, redshift, mental ray and arnold nodes
    • editable "Rename Dictionary" to meet you needs

  • File Management:

    • shader / asset rename, duplicate, copy & paste with
    • automatic "Texture File Repath Function"
    • open the selected shader/asset in maya
    • open selected asset in file browser

  • Path Tools:

    • display texture paths for whole scene or just for selected object(s)
    • find missing texture image files

  • Search Function

    • either search the current category or the whole library
    • search by using meta tags

  • Texture Tools

    • quickly convert relative paths to absolute paths or vice versa
    • collect (copy) all scene textures in current project folder or specify a custom folder

  • IPT  (interactive placement tool)

    • allows Assets import / placement with unparalleled ease

  • Material Picker

    • makes Assignment of Shaders a breeze

    Quick Install

    If you do not want to read through the full installation guide and you have enough experience installing plugins for Maya - please run through the following steps and you should be fine:

    1. Close down all running sessions of Autodesk Maya.
    2. Extract the contents of the SLiB_Browser_PRO_2.0.zip package to a  valid maya “plug-in” folder.
    3. Start-up Maya, go to the Plug-in Manager and find and turn on "Load" and  "Auto load" for “SLiB.py”.
    4. Make a choice in the “Browser Pro Library Setup” window.
    5. Start the Browser via the new SLiB shelf or by new menu entry “SLiB > SLiB Browser”.

    Installation

    If you are new user the please follow the steps bellow to correctly install the browser, if you are an existing user coming from an older version of the Browser, please go to Chapter "Upgrading".

    Please close-down Maya before you start with the installation

    Once you downloaded the plug-in from our website you will notice that the Browser PRO is contained within a *.zip package. This package holds all the individual files for Browser PRO to function. To access these files you will first need to extract them. On a Windows machine this can be easily done by right clicking on the package and choosing “extract all” from the right click context menu. A new window will open, asking you where you want the files to be extracted to. The quickest way is to directly extract it in your Maya plugin-in folder (see path list below).  It is recommended to use the following path:  “<user’s directory>/My Documents/maya/plug-ins” (user’s directory being different). This will let you use  the plug-in with every Maya Version installed.

      Default for Windows

        <user’s directory>/My Documents/maya/2017/plug-ins 
        <user’s directory>/My Documents/maya/plug-ins 
        <maya_directory>/bin/plug-ins 

      Default for OSX

        In your Home folder, under: Library/Preferences/Autodesk/maya/2017 
        Library/Preferences/Autodesk/maya/2017 <user’s directory>/My Documents/maya/2017/plug-ins 
        /Users/Shared/Autodesk/maya/2017  
        /Users/Shared/Autodesk/maya   
        Inside the Maya package in /Applications/Maya 2017/Maya.app   

      Default for Linux

        $MAYA_APP_DIR/maya/2017/plug-ins 
        $MAYA_APP_DIR/maya/plug-ins  
        /usr/autodesk/userconfig/maya/2017/plug-ins   
        /usr/autodesk/userconfig/maya/plug-ins 
        $MAYA_LOCATION/bin/plug-ins  

      Now before you will be able to use the Browse PRO you need to load the plug-in. Start up Maya and from Menu Bar choose“Windows  >  Settings/Preferences  >  Plug-in Manager”.In the new opened window find “SLiB.py” and check “Loaded” and “Auto load”.


      The Browser PRO Setup window will pop-up. There are three options to choose from:



      Default: Will set the library to be contained in the “core” of the SLIB Browser. This will mean that your library resides in in the same “plug-in” location as where you copied/extracted the SLiB files to. This Library also includes some “starter content” so you immediately have some example assets to play around with. This is ideal for people who just want to start using the Browser PRO right away. But there is a caveat when choosing this option. Accidently deleting the plugins folder in your Maya documents will also delete your complete library - so be warned! Also if you add or create a lot of Assets it can start holding a lot of GB’s of data. If you have a large C:\ drive and there is enough free space then this of course is no problem. 

      New: Will create a new SLiB Library on a location that the user specifies, This can be any folder on your workstation or even one located on NAS (Network Attached Storage Drive). This option will not hold any starter content and thus is the best choice if you want to start with a clean slate. Again please be aware that an Asset library can grow in size pretty rapidly. So it's best to choose a drive that has enough free space.

      Existing:  If you already have a SLiB library installed on your machine or if you reinstalled your machine and have made a backup of the Library that you want to set again -  this is the right option for you. 

      Hooray! A new menu entry called “SLiB” has been added to the Maya menu bar  as well as "SLiB Shelf". Start Browser PRO by either clicking the menu entry “SLiB" followed by "SLiB Browser” or by clicking the Browser icon.


      Making your old assets compatible with v2.0

      From version 2.0 and up Browser PRO will use an individual meta-data file holding extra information for each asset. Because assets from older versions of the browser don’t contain these meta-files we first need to create these for all our assets in the library. This process is called “Metarizing” and you need to manually do this for all your assets.

      Open an Asset Category then select all Assets (Ctrl + A) and from the Browser PRO window menu bar choose: "Tools > Metarize". Browser will now open up your Assets one by one collection the needed data and writing out the *.meta file.



      User Interface

      Overview

      Now that Browser PRO is installed properly we will start by taking a look at the User Interface and its individual User Interface elements. (From now on we will abbreviate “User Interface” as UI)
      Each UI element in Browser PRO has a UI specific task or functionality - like creating thumbnails for example.

      It’s important to know the names of the different UI elements because knowing them will help in better understanding the upcoming chapters.  You will understand what we are talking about when using terms like “Indexing Menu” or the “Library Switch” for example.



      MENU BAR
      Holds all the different menu entries
      ASSET TYPE
      Is used to switch between the different Asset Types like Shader, Objects, HDRI, etc. This UI element also contains the search field. Which is used to quickly find assets in your library based on name or metatag(s)
      SHELF
      The shelf contains tools and functions that are specific to the current Asset Type
      ASSET CATALOG
      The Catalog displays all the Assets in the current Category. This can be; objects, shaders, textures, hdri images, etc. But the type of asset that is shown, is limited to the mode that is currently active. So you will only see objects in the Asset Catalog when in “OBJECT” mode. The Asset Catalog is the core of the browser; it holds a lot of functionality like importing, opening, renaming, deleting etc.
      QA TOOLBAR
      Displays all the functions that are also accessable via the Asset Catalg RMB context menu.
      STATUS BAR
      The status bar will notify you when things went wrong, where completed etc. If something is not working the way you expected first take a look here
      NAME DISPLAY
      Shows the full name of an asset and the file extension
      THUMB DISPLAY
      Shows a medium size image thumbnail
      THUMB CREATOR
      The Thumbnail Creator is used to quickly create and assign preview images for your Assets
      INDEXING MENU

      EXPORT BUTTON
      The export button is used to export the selected object form a Maya scene to the currently active category
      LIBRARY SWITCH
      Is used for switching between multiple Libraries
      ASSET CATEGORIES
      Shows the folder structure of the current active module. So switching from “OBJECT” to “SHADER” will also change the active list in this UI element.

      In this chapter you can read all about the SLiB Browser PRO menu bar. We have broken up the UI in such a way that the shelf holds all tools and functions that are specific to a module. The menu bar on the other hand contains the overall functionality - like; saving preferences, handling how Imports are done and it also holds a Tools menu; for tools and functions that are intended for more overall use. And you can find the Help menu here, where you can find more information about the product itself.
      Load Shader Test scene
      Will open up a Maya scene, that holds a shader ball and a light-setup. It also has the render settings setup correctly, so you can immediately start rendering / testing your shaders.
      Dock Browser Window
      This will dock the Browser Window on the right-side of you Maya UI . This is an ideal mode,  when not working with a dual monitor setup. (obsolete in Maya 2017)
      Delete Confirmation
      With delete confirmation on, you will get an extra warning message before the Browser actually deletes the selected Asset(s).
      Auto Repath Textures
      With Auto repath on, the browser will automatically repath the textures paths on an object or shader, without first notifying the user. And by doing so, will close the current Maya scene.

      If it is set to off, the user will first get a pop-up window, where you can choose to continue with the action. Or you choose to first save your work.

      Repathing is needed because when you move or rename an Asset the actual location of the file is changed. This behavior would normally cause your textures to no longer be found.The Browser will always automatically counteract this by relinking the texture paths to the new location. 
      Save Settings
      Will write out a preference file that holds all the currently active settings. The next time you will start the Browser, it will go back in this state.  

      Example: If you choose to have “Delete Confirmation” on, and you push “save settings”. The next time you start up the Browser, this option will still be activated.

      As Reference
      Will import an object as a Maya Reference. This is ideal when working in teams or when you still want the ability to make changes to the model at a later moment without the need to replace it.
      Reuse Existing Asset
      When on Browser will reuse an Asset that is already imported in the scene. This can greatly improve performance, minimize file size and is ideal to make multiple changes to different instances all at once. This function can be set in two modes:

      Duplicate: Will create a duplicate of an object that is already in the scene itself. This is faster then re-importing it from a Maya file. But isn’t as “cost” efficient as using instances. You normally only use this when you want to make specific changes to the asset. that should not be applied to all other instances.

      Instance: Instancing is by far the most efficient way to create a lot of “duplicates” in your scene. What Maya does in the background is show the same Asset (“mesh”) on multiple locations at the same time. This way you can have thousands of duplicates of an object, with almost no extra “cost” on performance and file size. This is the advised method.

      If you turn this function off it will keep importing new versions of that asset every time you click import. This is the slowest and “cost” inefficient method. Should only be used in really specific situations.
      Reuse Existing Shader
      With delete confirmation on you will get an extra warning message before the Browser actually deletes the selected Asset(s).
      Copy Tex to Project Folder
      With Auto repath on, the browser will automatically repath the textures paths on an object or shader, without first notifying the user. And by doing so, will close the current Maya scene.

      If it is set to off, the user will first get a pop-up window, where you can choose to continue with the action. Or you choose to first save your work.

      Repathing is needed because when you move or rename an Asset the actual location of the file is changed. This behavior would normally cause your textures to no longer be found.The Browser will always automatically counteract this by relinking the texture paths to the new location. 

      Metarize
      Browser PRO 2.0 uses an individual “Meta File” per Asset that contains data that is needed for a lot of functions. For example: it holds  the bounding box size of an object, so that tools like IPT know how big the object is before it gets placed in the scene.

      When exporting an asset into the library Browser PRO 2.0 will automatically "metarize" your Asset. but in some cases you need to do this by hand.

      An example of this is when a new version of the browser has been released that holds new meta-functionality. Your old Assets then need to be upgraded to support this latest version of the browser. You then select all Assets in a category and click “Metarize”. These Assets will now be compatible with the latest version.
      Shading Network Renamer
      Used for organizing your shading networks 
      Load from Zip
      comming soon...
      Load from Store
      comming soon...
      vRayMat to rsMat (Alpha)
      This tool converts Vray Materials to Redshift Materials.

      Snapshot Framing
      used only internally
      Icon Toolbar
      The Icon Toolbar is an extra toolbar that can be visible or hidden, it holds all the basic functionality that is normally found under the RMB context menu like; “Import”, “Duplicate”, “Rename”, “Copy” etc.
      Thumb Meta Overlay
      Thumb Meta overlay can overlay small thumbnails on the assets listed in the category.  So you can easily see for what render-engine the shader was intended.

      The bad thing is that is slows down the Browser significantly, on bigger categories it’s best to have it turned off.
      Show Folder Thumbs
      Display your Asset Categories as thumbnails. 
      Disable Thumbs in Hypershade
      When working with high resolution textures or complex shaders Maya can slow down tremendously, because with every change you make, Maya will start recalculating the resulting shader. If you start noticing this behavior, you can switch this option on to regain working speed.

      Let's you quickly shift between all available Render Engines.

      Tool Shortcuts
      Will pop up small window showing the Shortcuts for tools like IPT or Material Picker.
      User Manual
      This on brought you here ;)
      About
      ...us

      Asset Type Bar


      Icon
      Description
      RMB Context Menu
      Shader
      Objects or Scenes
      Lights
      HDRi
      Image Textures
      Texture Paths
      Enable the meta tag search functionality. Because this function will increase search times it’s best to only turn this on, when needed.
      Start Search Button
      Clear: 
      Will clear the search field and refresh the Asset Catalog.

      Shelf

      Icon
      Description
      RMB Context Menu
      Let’s you toggle between different resolutions for the thumbnails in the Asset Catalog.
      Will pop-up a list that can be used to switch between predefined resolutions.
      Clicking on this button will refresh the contents of the Asset Catalog.

      Asset Catalog

      Icon
      Description
      RMB Context Menu
      coming soon...
      coming soon...

      Thumbnail Display

      Element
      Description
      Shows a medium size resolution image of the selected Asset. It will automatically refresh the thumbnail when you click on a different asset. It will also automatically display newly rendered thumbnails.

      A double click opens the full size image window.
      RMB Context Menu
      Reset
      Will reset the Thumbnail Display back to the default “SLiB Browser Pro” image.
      Replace
      Replaces the thumbnail of (a) currently selected Asset(s) by  a newly rendered or imported one. This is intended to be used along with the “Lock Preview Image” from the Thumbnail Grabber UI element

      Thumbnail Creator

      Icon
      Description
      RMB Context Menu
      Will Generate thumbnails for all selected Assets in a “Asset Catalog”. This function is ideal when you want to render thumbnails for one or more of your assets. The Browser does this in the background so that you can continue working. The Preview Image Generator uses the “REND” Meta data. So you need to be sure that it is set correctly before you activate it.
      SHADER

      Ball: renders selected shader(s) on a shperical object
      Cube:  renders selected shader(s) on a cubic object
      Cloth: renders selected shader(s) on a cloth shaped object
      Holder: renders select. shader(s) on a so called "Shaderball" object
      OBJECTS

      Front: renders selected object(s) frontal 
      Persp Right: renders selected object(s) from a right perspective
      Persp Left: renders selected object(s) from a left perspective
      Will do a normal render with the resolution set to 512x512, and then send it to the “Thumbnail Display”.
      Snapshot Framing: LMB double click will toggle the Snapshot Framing on or off on selected camera. This is ideal for correctly framing your shot.
      Will take a Snapshot from the viewport with a 512x512 resolution
      Snapshot Framing: LMB double click will toggle the Snapshot Framing on or off on selected camera. This is ideal for correctly framing your shot.
      Will manually grab the last rendered image from the Maya framebuffer and send it to the “Thumbnail Display”
      Will load a preview image from your hard drive. This is particularly useful when you have downloaded a model pack that already has the Preview Images included. This way you can quickly load and set Preview Images to imported Assets without the need to render them yourself.
      Will lock the “Thumbnail Display” and thus it will stop refreshing when a different asset has been selected. This is used mostly to replace a thumbnail with a different one.

      Working with...

      Shaders


      1. select the category folder where the shader will be saved on top of the other shaders 

      b. or select ROOT and RMB to generate a new category folder for the new shaders

      (with BP you´re able to create for every project an own folder - perfect for sharing or backup´s, or restoring projects)

      2. Reset the preview image window with RMB/RESET - otherwise the new shader get´s the wrong preview image



      3. Select the object with the shader you will save in BP

      4. Fill in the new shader name (or RMB use “take from selected”, etc.)

      5. Now click “Export Shader”, to export the selected shader with the new name to BP

      6. the saved shader appears in the shader view with his new name and the default preview image



      7. render preview image by first clicking the desired shader and then click the “generate preview image” button.

      A background process start´s automatically, renders the preview image, and when it´s finished it replaces automatically the preview image in the shader lib.



      a. You can generate more than one preview image by selecting as many shaders as you want, or all shaders in the actual lib and press “render preview image” button ones.

      The background render process starts and render all preview images automatically in once.

      b. With RMB on the “render preview image” button, you can choose between 4 different preview image modes. Ball, Cube, Cloth or Holder.



      While rendering in background you see the green process indicator at the bottom of the BP window.

      It returns to grey when it´s finished.


      8. Additional options



      With RMB on the selected shader, you can use some more shader operations

      a. Import

      Imports the shader into the actual maya scene, to work with

      b. Open in Maya

      Load´s the shader, which is saved as “name.ma” file in the BP lib folder, as a maya scene.

      Now it´s possible to tweake the shader and save/overwrite it per “Save Scene” in maya File menue.

      From now on, the shader is available in only the tweaked version.

      c. Open in File Browser

      Opens the depending folder with the windows file browser.

      Can be used for fast orientation, or fast organizing things like backups or sharing with 3D Partners.

      d. Dublicate, Rename and Delete

      Is self explaning

      e. Copy

      Per copy it´s possible to copy a shader from one one lib to another


      Loading into Maya

      The Import pulldown menu has tow settings for shader import.

      (what means that a shader, saved into the BP library will now into the actual maya scene)



      a. “Reuse Existing shader” (which is default) or not reuse

      b. copy “TEX to Project Folder” is self explaned

      1. Select one or more objects, you plan to get a new shader from BP

      2. Double click on the shader you wish to use

      … the new shader is imported into maya and assigned to the selected objects

      (no odds if Reuse is on or off)

      Working with “Reuse” ON:

      a. When you select one object and make a double click on a shader, the shader is loaded into maya and assigned to the first object.

      b. When you select a second/another object and make a double click on the same shader, it it will not be imported into maya again, but assigned with the existing one in hypershade, to the new object too.

      Working with “Reuse” OFF:

      a. s.o.

      b. When you select a second/another object and make a double click on the same shader, it it will be imported into maya again, and assigned to the new object.

      Now you´ve the same shader twice inside hypershade and you can tweak a variation of the shader. (it´s the same like “copy shading network” inside hypershade)


      Editing saved shaders

      As example...It may be, that you decide to use lower or higher subdivision samples in future.

      Navigate to the shader, RMB on it´s icon and confirm “OPEN In Maya “.



      A warning appears, that BP will close the actual scene. That´s nessesary because all assets are saved as ma-scenes and can only be modified inside maya.

      (Here you can see the structure, when you say “OPEN In FileBrowser”.)



      After proceeding with “Yes” the shader is loaded and can be tweaked.

      When you´re finish with tweaking overwrite the ma-file per “Save Scene”.



      Now the shader is updated and ready for future use.

      (This is not reversible!)


      Objects

      Before you export objects for future projects into BP2 consider this fact:

      The history, and the pivots could be changed, also they will be freezed.

      It´s recommended to do this after finishing the work and after final saving the scenes


      1. select the objects category folder where the objects/Assets will be saved



      b. or select ROOT and RMB to generate a new category folder for the new objects

      (with BP you´re able to create for every project an own folder - perfect for sharing or backup´s, or restoring projects)


      2. Reset the preview image window with RMB/RESET - otherwise the new object get´s the wrong preview image



      3. Select the object you will save in BP

      4. Fill in the new shader name (or RMB use “take from selected”, etc.)

      5. In the Index menu make some decisions

      a. delete history, freeze transformations, snap pivot to origin while exporting (default ON)



      b. save objects as mb, ma or OBJ files (default MB)



      6. Now click “EXPORT OBJECTS”, to export the selected object with the new name to BP

      7. the saved object appears in the objects view with it´s new name and the default preview image



      8. Render the preview image by selecting the desired asset and then click the “Generate Preview Image” button.


      With the RMB on the render button, a pull-down menu appears. You can decide on three different camera views, you want to render!



      A background process start´s automatically, renders the preview image, and when it´s finished it replaces automatically the preview image in the shader lib.



      NOTE on Preview image

      a. If you forgot do clear the preview image window, it happens that the next exported asset get the same preview image.

      - To correct this, simple render the preview with the selected asset again.

      b. To edit your saved objects (shading, modelling, etc) RMB on the desired asset.

      (before you do that save your work, because editing assets needs to load them into maya!)



      Now select OPEN in Maya and it will be loaded to allow to edit the file.

      Let´s say we decide to edit the color from orange to blue and scale the pot more flat.

      After that you only have to overwrite the maya scene per “File / Save Scene”.

      The revised object is saved and overwritten. With a new “render sample image” command, the thumbnail will be updated.


      TIP 1 - In some cases it can be usefull to ad variations into your asset.

      Let´s say a white vase in more color variations.

      Load it into maya as described above, copy the vase and the shader and create a black variation. Press “h” to hide it (maya visibility) and overwrite your asset - that´s it.

      In future you are able to decide which version you will use, very easy and fast.


      Loading objects/assets into your Maya scene

      RMB on the asset:

      a. “IMPORT” imports the object at zero position (or double click onto the asset icon)

      b. “IMPORT and Place at Selection” do exact what it mean

      c. “IMPORT and Replace Selection” deletes the selected object in the scene and place the new object at the same position.

      A very simple and fast way, to see which object is the nicer one at that place!


      Editing saved objects

      That´s the same procedure as for shaders


      Lights

      Importing and exporting lights to/from BP is nearly the same than described above.

      Because of different handling with different render engines it need to work a bit different.

      In this case, Vray moves the Lights to the origin and rotate them to their default settings, when using the freeze function. (What you not want in some cases)

      To avoid rotate and move the light to wrong positions: